Jump to content


Photo

Alternator Died ?


  • Please log in to reply
5 replies to this topic

#1 kmidderigh

kmidderigh

    Super Member

  • 346 posts
  • Gender:Male
  • Location:Horsham

Posted 16 December 2018 - 08:18 PM

Pretty sure my alternator has died today...
 
Was out for a drive (car started instantly on ignition) and after about 40 minutes started seeing the same symptoms as in this post :
 
 
but this time also got a flickering battery light occasionally and noticed the wipers going slower and slower.
 
Timed it well and pulled into a pub car park to check diagnosis...once stopped car wouldn't start again. completely dead.
 
Sat in the pub for a while waiting to be recovered home (could have been worse ;-) ).
 
Once car was off the recovery vehicle at home managed to start it again to park it (battery rested for about 2 hours) but after that dead again (was hoping to measure the charging voltage but not today - hopefully tomorrow after battery has had a rest)
 
Battery measuring 12.1 volts with engine off
 
Sound like alternator ?


#2 vocky

vocky

    vx220 itb

  • 11,617 posts
  • Gender:Male
  • Location:Earth

Posted 17 December 2018 - 11:08 AM

A healthy alternator should kick out at least 13.5v, so if it's less than that it really needs replacing

 

also worth checking that the battery positive terminal is not shorting out on the chassis and that the battery terminals are on secure



#3 ElizP987

ElizP987

    ....

  • 4,030 posts
  • Gender:Female
  • Location:St.Helens, Merseyside

Posted 21 December 2018 - 09:24 AM

hi have a couple if you need another



#4 chris_uk

chris_uk

    I fancy chill

  • PipPipPipPipPipPipPip
  • 9,767 posts
  • Gender:Male
  • Location:Leeds UK

Posted 21 December 2018 - 06:42 PM

If you want a brand new 100Amp one i do them for £110 delivered in UK.



#5 kmidderigh

kmidderigh

    Super Member

  • 346 posts
  • Gender:Male
  • Location:Horsham

Posted 22 December 2018 - 09:37 PM

Thanks for the offers...just managed to restart it today to measure the charging voltage...under 12 whilst running.
Already booked into BackonTrack for some body work so they are going to sort it early Jan.

#6 kmidderigh

kmidderigh

    Super Member

  • 346 posts
  • Gender:Male
  • Location:Horsham

Posted 21 February 2019 - 08:39 PM

just to confirm this was a failed alternator - now replaced and all running fine again :-)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users