Jump to content


Photo

P0340 In Op-Com

p0340

  • Please log in to reply
6 replies to this topic

#1 shimizou

shimizou

    Newbie

  • 4 posts
  • Location:Japan

Posted 09 September 2019 - 06:55 AM

My VX220 has a P0340 in Op-Com. I heard Z22 doesn't have camshaft position sensor.
Could you guess what's problem with my VX220?
Please help me!!

 



#2 Rosssco

Rosssco

    Scary Internerd

  • 4,077 posts
  • Gender:Male
  • Location:Aberdeen

Posted 09 September 2019 - 07:28 AM

Might be an issue with the coilpack, as this is used to detect cylinder compression, and therefore cam position.



#3 shimizou

shimizou

    Newbie

  • 4 posts
  • Location:Japan

Posted 09 September 2019 - 10:56 PM

I forgot to write.
‚ÄčI had already replaced coil pack and sparkplug because first holt code was P0300 (Random/Multiple Cylinder Misfire detected)
After I had replaced coil pack and sparkplug, P0340 had came up.
 



#4 shimizou

shimizou

    Newbie

  • 4 posts
  • Location:Japan

Posted 09 September 2019 - 10:58 PM

And even though the water temperature is low, the radiator fan works.



#5 ciderbooze

ciderbooze

    Need to get Out More

  • PipPipPipPip
  • 1,213 posts
  • Gender:Male
  • Location:Sunny skelton
  • Interests:cars, fishing, beer, football.

Posted 10 September 2019 - 02:34 PM

Did you fit a Pattern part coil pack or genuine? The fan comes on with certain faults regardless of water temp.

#6 shimizou

shimizou

    Newbie

  • 4 posts
  • Location:Japan

Posted 11 September 2019 - 02:32 AM

Coil pack is not genuine. I bought from China. 
Do you think this is the cause?



#7 Foxy

Foxy

    I love Nev

  • 10,486 posts
  • Gender:Male
  • Location:Lichfield

Posted 11 September 2019 - 03:45 AM

Put the old coil pack back in.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users