Jump to content


Photo

Z22Se Hard Cold Start


  • Please log in to reply
2 replies to this topic

#1 vpreda2003

vpreda2003

    Newbie

  • 3 posts
  • Location:Bucharest, Romania

Posted 22 February 2020 - 08:18 PM

Hello,
From time to time, at lower temperature (under 5 degree Celsius), my engine starts very hard. Maybe after 10 seconds of cranking. After starting, everything is normal. No stall, no lack of power. Sometime it start at first second. Remember, this is happenning only at cold engine. I don't have EGR, I had cleaned TB, changed Coil Pack etc.
Please help,
Thank you!


#2 TheHood

TheHood

    Need to get Out More

  • PipPipPipPip
  • 995 posts
  • Gender:Male
  • Location:Midlands
  • Interests:World domination, a liking of unconvincing disguises, Malaysian temple restoration and nice words like "flange".

Posted 23 February 2020 - 11:37 AM

How old is the battery? Maybe its cold cranking amps ain't what they used to be.

#3 FLD

FLD

    WANNABE MY LOVER

  • PipPipPipPipPipPipPipPip
  • 13,464 posts
  • Gender:Male
  • Location:Near nantwich
  • Interests:Tugging my todger.

Posted 24 February 2020 - 08:59 AM

Do you have fuel pressure?  I had a problem with the valving in the pump that manifested in a similar way.  Turn the key, pump primes but still mega hard to start.  Check the pressure at the rail, you should get a good squirt of fuel out of the valve.  If it's just a small trickle the pump is likely shot.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users