Jump to content


Photo

Vx Specialist South East? Running Problems.


  • Please log in to reply
19 replies to this topic

#1 Johnnyjap

Johnnyjap

    Member

  • Pip
  • 12 posts
  • Location:horsham

Posted 22 June 2020 - 03:48 PM

Hi all,

 

Does anyone have any recommendations who to send my poorly 2.2 sc too? I bought Sebs old SC from Jon Seal end of last year.  It keeps occasionally losing power and hunting erratically and only resets when I turn the key off and on again when driving! Took for a spin today and was good for 10 minutes then started doing again.  Ive checked the sparkplugs and all looks dry.

 

Thanks John



#2 Strugs

Strugs

    World's #1 cheese fan

  • 2,984 posts
  • Gender:Male
  • Location:Farnham, Surrey

Posted 22 June 2020 - 07:36 PM

Back On Track in Guildford.

#3 BrianJ

BrianJ

    Member

  • Pip
  • 176 posts
  • Gender:Male
  • Location:Horsham W Sussex

Posted 22 June 2020 - 07:39 PM

Or Plans who are a tad closer to Horsham but I've had really good service from both BoT and Plans so would happily recommend either.

 

BrianJ



#4 Madmitch

Madmitch

    Super Duper Member

  • PipPipPip
  • 513 posts
  • Gender:Male
  • Location:South of France

Posted 22 June 2020 - 08:24 PM

Sounds like the air mass sensor.



#5 ICD

ICD

    Member

  • Pip
  • 87 posts
  • Location:UK

Posted 23 June 2020 - 07:52 AM

Matt Bentley Racing...nr Bedford, specialist in fault finding



#6 fiveoclock

fiveoclock

    Whipping Boy

  • 9,423 posts
  • Gender:Male
  • Location:Ifold, West Sussex

Posted 23 June 2020 - 10:22 AM

Didn't know they'd moved Bedford

#7 Johnnyjap

Johnnyjap

    Member

  • Pip
  • 12 posts
  • Location:horsham

Posted 23 June 2020 - 06:28 PM

Back On Track in Guildford.

 

 

Or Plans who are a tad closer to Horsham but I've had really good service from both BoT and Plans so would happily recommend either.

 

BrianJ

 

 

Sounds like the air mass sensor.

 

 

Matt Bentley Racing...nr Bedford, specialist in fault finding

 

Thanks for the replies - Bedfords a tad too far Im near Crawley



#8 scw02102

scw02102

    Billy No Mates

  • PipPipPipPipPip
  • 1,566 posts
  • Gender:Male
  • Location:Kent

Posted 24 June 2020 - 03:41 PM

I'm Kent and use Back on Track for the past 7 years plus

Worth the drive isn't much Jez doesn't know

#9 siztenboots

siztenboots

    RaceMode

  • 26,587 posts
  • Gender:Not Telling
  • Location:Surrey
  • Interests:french maids

Posted 26 June 2020 - 02:12 PM

does it still have the exhaust gas valve EGR fitted or has it been blanked off?



#10 Johnnyjap

Johnnyjap

    Member

  • Pip
  • 12 posts
  • Location:horsham

Posted 29 June 2020 - 05:58 PM

does it still have the exhaust gas valve EGR fitted or has it been blanked off?

 

EGR blanked off. Been told maybe an actuator issue - drives fine/boosts for a minute or 2 then loss of power and have to rest by key! 



#11 The Batman

The Batman

    Super Moderator

  • 30,234 posts
  • Gender:Male
  • Location:FLD mum's bed

Posted 29 June 2020 - 06:00 PM

map sensor



#12 Johnnyjap

Johnnyjap

    Member

  • Pip
  • 12 posts
  • Location:horsham

Posted 29 June 2020 - 06:00 PM

I'm Kent and use Back on Track for the past 7 years plus

Worth the drive isn't much Jez doesn't know

 

Thanks mate - maybe an option Ive got a local garage going to read the codes. My friend thinks its actuator another maf really confused whats going on.



#13 The Batman

The Batman

    Super Moderator

  • 30,234 posts
  • Gender:Male
  • Location:FLD mum's bed

Posted 29 June 2020 - 06:14 PM

im in alyesbury, buckinghamshire

 

it sounds like map sensor to me



#14 FLD

FLD

    WANNABE MY LOVER

  • PipPipPipPipPipPipPipPip
  • 13,526 posts
  • Gender:Male
  • Location:Near nantwich
  • Interests:Tugging my todger.

Posted 01 July 2020 - 03:20 PM

Map or some weird LOD.



#15 Johnnyjap

Johnnyjap

    Member

  • Pip
  • 12 posts
  • Location:horsham

Posted 01 July 2020 - 08:04 PM

im in alyesbury, buckinghamshire

 

it sounds like map sensor to me

 

 

Map or some weird LOD.

 

Cheers guys. Well looks like its the map sensor got damp. Hopefully helps if someone else has the same issues as me.



#16 Cavturbo

Cavturbo

    Super Member

  • PipPip
  • 272 posts
  • Location:Leamington Spa/Nuneaton

Posted 01 July 2020 - 08:15 PM

Replace or dry it out?

#17 FLD

FLD

    WANNABE MY LOVER

  • PipPipPipPipPipPipPipPip
  • 13,526 posts
  • Gender:Male
  • Location:Near nantwich
  • Interests:Tugging my todger.

Posted 02 July 2020 - 08:07 AM

It's worth checking your laminova seals.  I had an issue with blowing maps and it turned out I was getting coolant on the sensor from the laminovas.  It was a very mild leak so infrequent top ups but inside the manifold was wet with about 1cm of water in the very bottom.



#18 DJ_SL

DJ_SL

    Super Member

  • PipPip
  • 420 posts
  • Gender:Male
  • Location:Docklands,London, UK

Posted 06 July 2020 - 01:17 PM

Probably a little late but fwiw recommend Plans. They've been handling mine for the last 10+ yrs. Great service.

Sent from my Pixel 2 using Tapatalk



#19 leevx2.2

leevx2.2

    Turbo's are for girls and throttle bodies are too slow

  • 4,830 posts
  • Gender:Male
  • Location:Bedford
  • Interests:Taking apart vx220s for fun
    getting p!!sed
    genraly playing with large power tools

Posted 06 July 2020 - 06:45 PM

Yes map sensor 



#20 The Batman

The Batman

    Super Moderator

  • 30,234 posts
  • Gender:Male
  • Location:FLD mum's bed

Posted 09 July 2020 - 12:11 AM

It's worth checking your laminova seals.  I had an issue with blowing maps and it turned out I was getting coolant on the sensor from the laminovas.  It was a very mild leak so infrequent top ups but inside the manifold was wet with about 1cm of water in the very bottom.

 

i have brand new seals and end plate gaskets in stock :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users